読者です 読者をやめる 読者になる 読者になる

謎言語使いの徒然

適当に気になった技術や言語を流すブログ。

Scala2.10でかなり苦戦した

日記

inteliJ 使ってるわけなんだが、どうもこいつが現時点で対応しきれていないらしい。
i加えて、playframework 2.1.0 も正式に scala 2.10 に対応していないくさい。
iそのため、idea コマンドで出来上がったプロジェクトだと誤補完とかなにやらで地獄を見る。

i正式対応待ってもいいけど、ここはScalaを2.9系に落とす判断をしたほうが建設的。
i下位互換ぶった切って上げるからなぁScala、、、、

原因不明だが。scalableプラグインが壊れて依存jarから補完出来ないとか、謎補完が勝手に走るとか、明らかに読み込めてる関数やクラスを補完できないとか起きてた。
プラグインを削除していれ直したら復活。
長時間使うとエディタも壊れるし結構不安定なのかもしれない。