読者です 読者をやめる 読者になる 読者になる

謎言語使いの徒然

適当に気になった技術や言語を流すブログ。

Mac OS 10.10 にアップデートしたら、InteliJ が動かなかったので対処した

日記

原因:エラーログ眺めたら、JDK 8 のなんかのライブラリがロードできないと言って落ちているらしい。
要するに JVM 8 に InteliJ が対応できてないのだと思われる。

お待ちかねの対処

  1. まずは Java SE - Downloads | Oracle Technology Network | Oracle ここから JDK7 をダウンロードする
  2. 気にせずインストールする(コンソール上では変わらず 1.8.0_11 が動くがこれでok)
  3. ターミナル開いて、vi /Applications/IntelliJ\ IDEA\ 13\ CE.app/Contents/Info.plist で設定開く
  4. 下記の定義を探して、「1.6」を「1.7」に書き換えて保存したら完了
      <key>JVMVersion</key>
      <string>1.6*</string>

あとは普通に起動した。